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Introduction 

 

LoadRunner enables you to test your system under controlled and peak load 

conditions. To generate load, LoadRunner runs thousands of Virtual Users that are 

distributed over a network. Using a minimum of hardware resources, these Virtual Users 

provide consistent, repeatable, and measurable load to exercise your application just as 

real users would. LoadRunner’s in-depth reports and graphs provide the information that 

you need to evaluate the performance of your application.  

 

 LoadRunner emulates an environment in which thousands of users work with a 

client/server system concurrently. To do this, LoadRunner replaces the human user with a 

virtual user (Vuser). The actions that a Vuser perform are described in a Vuser Script.  

 

The LoadRunner advantages over Manual performance testing:  

 

 LoadRunner reduces the personnel requirements by replacing human users with 

virtual users or Vusers. These Vusers emulate the behavior of real users— 

operating real applications.   

 Because numerous Vusers can run on a single computer, LoadRunner reduces the 

hardware requirements.  

 The LoadRunner Controller allows you to easily and effectively control all the 

Vusers—from a single point of control.   

 LoadRunner monitors the application performance online, enabling you to fine-

tune your system during test execution.   

 LoadRunner automatically records the performance of the application during a 

test. You can choose from a wide variety of graphs and reports to view the 

performance data.   

 LoadRunner checks where performance delays occur: network or client delays, 

CPU performance, I/O delays, database locking, or other issues at the database 

server. LoadRunner monitors the network and server resources to help you 

improve performance.   

 Because LoadRunner tests are fully automated, you can easily repeat them as 

often as you need.  
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Some of the most commonly used Terms  in the LoadRunner 

 

 

Scenarios:  Using LoadRunner, you divide your application performance testing 

requirements into scenarios. A scenario defines the events that occur during each testing 

session. Thus, for example, a scenario defines and controls the number of users to 

emulate, the actions that they perform, and the machines on which they run their 

emulations. 

 

Vusers:  In the scenario, LoadRunner replaces human users with virtual users or Vusers. 

When you run a scenario, Vusers emulate the actions of human users working with your 

application. While a workstation accommodates only a single human user, many Vusers 

can run concurrently on a single workstation. In fact, a scenario can contain tens, 

hundreds, or even thousands of Vusers.  

 

 

Vuser Scripts: The actions that a Vuser performs during the scenario are described in a 

Vuser script. When you run a scenario, each Vuser executes a Vuser script. The Vuser 

scripts include functions that measure and record the performance of your application’s 

components.  

 

 

Transactions: To measure the performance of the server, you define transactions. A 

transaction represents an action or a set of actions that you are interested in measuring. 

You define transactions within your Vuser script by enclosing the appropriate sections of 

the script with start and end transaction statements. For example, you can define a 

transaction that measures the time it takes for the server to process a request to view the 

balance of an account and for the information to be displayed at the ATM. 

 

 

Rendezvous points:  You insert Rendezvous points into Vuser scripts to emulate heavy 

user load on the server. Rendezvous points instruct Vusers to wait during test execution 

for multiple Vusers to arrive at a certain point, in order that they may simultaneously 

perform a task. For example, to emulate peak load on the bank server, you can insert a 

rendezvous point instructing 100 Vusers to deposit cash into their accounts at the same 

time. 

 

Controller:  You use the LoadRunner Controller to manage and maintain your scenarios. 

Using the Controller, you control all the Vusers in a scenario from a single workstation.  
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Load generator:  When you execute a scenario, the LoadRunner Controller distributes 

each Vuser in the scenario to a load generator. The load generator is the machine that 

executes the Vuser script, enabling the Vuser to emulate the actions of a human user.  

 

Performance analysis: Vuser scripts include functions that measure and record system 

performance during load-testing sessions. During a scenario run, you can monitor the 

network and server resources. Following a scenario run, you can view performance 

analysis data in reports and graphs.  

 

 

LoadRunner Vuser Types  
 

LoadRunner has various types of Vusers. Each type is designed to handle 

different aspects of today’s system architectures. You can use the Vuser types in any 

combination in a scenario in order to create a comprehensive application test. The 

following Vuser types are available:   

 

 Client/Server :  For MSSQLServer, ODBC, Oracle (2-tier), DB2 CLI, Sybase 

Ctlib, Sybase Dblib, Windows Sockets and DNS protocols.  

 

 Custom: For C templates, Visual Basic templates, Java templates, Javascript and 

VBScript type scripts.  

 

 Distributed Components: For COM/DCOM, Corba-Java, and Rmi-Java 

protocols.  

 

 E-business: For FTP, LDAP, Media Player, Multi Protocol Web/WS, Web 

(HTTP, HTML), Palm, and RealPlayer protocols.  

 

 Enterprise Java Beans:  For EJB Testing and Rmi-Java protocols.  

 

 ERP:  For Oracle NCA, Peoplesoft (Tuxedo), SAP, and Siebel protocols.   

 

 Legacy:  For Terminal Emulation (RTE).  

 

 Mailing Services: Internet Messaging (IMAP), MS Exchange (MAPI), POP3, and 

SMTP.   

 

 Middleware:  For the Tuxedo (6, 7) protocol.   

 

 Wireless:  For i-Mode, VoiceXML, and WAP protocols.  
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The LoadRunner Testing Process  
 

 

You can easily create and run load-test scenarios by following the LoadRunner 

testing process below. The following illustration outlines the testing process:  

 

 
 

 

Step I: Planning the Test  

 

Successful load testing requires that you develop a thorough test plan. A clearly 

defined test plan will ensure that the LoadRunner scenarios that you develop will 

accomplish your load testing objectives.   

 

Step II: Creating the Vuser Scripts   

 

Vusers emulate human users interacting with your Web-based application. A 

Vuser script contains the actions that each virtual user performs during scenario 

execution.  

 

In each Vuser script you determine the tasks that will be:  

 

 Performed by each Vuser  

 Performed simultaneously by multiple Vusers  

 Measured as transactions  
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Step III: Creating the Scenario  

 

A scenario describes the events that occur during a testing session. A scenario 

includes a list of machines on which Vusers run, a list of scripts that the Vusers run, and a 

specified number of Vusers or Vuser groups that run during the scenario. You create 

scenarios using the LoadRunner Controller.  

 

Creating a Manual Scenario You create a scenario by defining Vuser groups to 

which you assign a quantity of individual Vusers, Vuser scripts, and load generators to 

run the scripts. You can also create a scenario using the Percentage Mode, in which you 

define the total number of Vusers to be used in the scenario, and the load generator 

machines and percentage of the total number of Vusers to be assigned to each Vuser 

script. Creating a Goal-Oriented Scenario For Web tests, you can create a goal-oriented 

scenario, in which you define the goals you want your test to achieve. LoadRunner 

automatically builds a scenario for you, based on these goals.  

 

Step IV: Running the Scenario   

 

You emulate user load on the server by instructing multiple Vusers to perform 

tasks simultaneously. You can set the level of load by increasing and decreasing the 

number of Vusers that perform tasks at the same time.  

 

Before you run a scenario, you set the scenario configuration and scheduling. This 

determines how all the load generators and Vusers behave when you run the scenario. 

You can run the entire scenario, groups of Vusers (Vuser groups), or individual Vusers. 

While a scenario runs, LoadRunner measures and records the transactions that you 

defined in each Vuser script. You can also monitor your system’s performance online. 

 

Step V: Monitoring a Scenario   

 

You can monitor scenario execution using the LoadRunner online run-time, 

transaction, system resource, Web resource, Web server resource, Web application server 

resource, database server resource, network delay, streaming media resource, firewall 

server resource, ERP server resource, and Java performance monitors. 

 

Step VI: Analyzing Test Results   
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During scenario execution, LoadRunner records the performance of the 

application under different loads. You use LoadRunner’s graphs and reports to analyze 

the application’s performance.  
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Creating the Vuser Scripts 
 

 

The structure and content of a Vuser script differ from one Vuser type to another. 

For example, Database Vuser scripts always have three sections, are written in a code that 

resembles C, and include SQL calls to a database server. In contrast, GUI Vuser scripts 

have only one section, and are written in TSL (test script language). 

 

The following diagram outlines the process of developing a Vuser script. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You begin the process of developing a Vuser script by recording a basic script. 

LoadRunner provides you with a number of tools for recording Vuser scripts. You 

enhance the basic script by adding control-flow structures, and by inserting transactions 

and rendezvous points into the script. You then configure the run-time settings. The run-

time settings include iteration, log, and timing information, and define how the Vuser will 

behave when it executes the Vuser script. To verify that the script runs correctly, you run 

it in stand-alone mode. When your script runs correctly, you incorporate it into a 

LoadRunner scenario.  

 

 

 

 

   Record a basic Vuser script 

Enhance/edit the Vuser script 

Configure Run-Time settings 

 

Run the Vuser script in stand-   

alone mode 

Incorporate the Vuser script 

into a LoadRunner scenario 
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Introducing VuGen 
 

The Virtual User Generator, also known as VuGen, enables you to develop Vuser 

scripts for a variety of application types and communication protocols. 

 

VuGen not only records Vuser scripts, but also runs them. Running scripts from 

VuGen is useful when debugging. It enables you to emulate how a Vuser script will run 

when executed as part of a scenario. When you record a Vuser script, VuGen generates 

various functions that define the actions that you perform during the recording session. 

VuGen inserts these functions into the VuGen editor to create a basic Vuser script. 

 

The inserted functions include general Vuser functions and protocol-specific Vuser  

functions: 

 

 The general Vuser functions are also known as LR functions. They can be used in 

any type of Vuser script. There are separate LoadRunner functions for C and  Java. 

 

 The protocol-specific Vuser functions are specific to the Vuser type. For  

example, VuGen uses LRT functions in a TUXEDO script, and LRS functions in a 

Windows Sockets script. 

 

 

Vuser Script Sections 
 

Each Vuser script contains at least three sections: vuser_init, one or more Actions, 

and vuser_end. Before and during recording, you can select the section of the script into 

which VuGen will insert the recorded functions.  

 

The following table shows what to record into each section, and when each 

section is executed. 

  

Script Section Used when recording... Is executed when... 

vuser_init A login to a server The Vuser is initialized 

(loaded) 

Actions Client activity The Vuser is in “Running” 

status 

vuser_end A logoff procedure The Vuser finishes or is 

stopped 

 

 

When you run multiple iterations of a Vuser script, only the Actions sections 

of the script are repeated—the vuser_init and vuser_end sections are not repeated.  
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Recording Web Vuser Scripts with VuGen   

 
1. Select Start > Programs > LoadRunner > Virtual User Generator. The VuGen main 

window opens. 

 

 

                   
 

2. Select File > New or click the New button . The New Virtual User dialog box 

opens.           
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3. Select Web (HTTP/HTML) from the All Protocols list or from the E-Business folder, 

and click OK. VuGen opens a skeleton Vuser script. 

 

4. Select Vuser > Start Recording, or click the Start recording button on the VuGen 

recording toolbar. The Start Recording dialog box opens. 

 

 

                     
 

 

5. Click Options to set the recording mode, browser, proxy, and additional recording 

options.  

 

6. Type a Web site address (URL) in the URL box, or select one from the list. This is 

where you will start recording the script. 

 

7. From the Record into Action list, select the action into which you want to begin 

recording, or create a new action. 

 

To create a new action, click the New button. The Create new action dialog box opens. 

 

 

                               
 

Type a name for the new action in the Action name box, or accept the  default name, and 

click OK. When you create a new action, VuGen adds it to the Actions list in the skeleton 

Web Vuser script. 

 

8. Click OK to launch the Web browser and start recording. The floating recording    

toolbar appears. 

 

9. Navigate through your Web site by clicking hypertext and hypergraphic links, and 

submitting forms. Each link you click adds an Action icon to the Web Vuser script. Each 

form you submit adds a Submit Form icon to the Vuser script. 
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10. After performing all the required user processes, click the Stop Recording button on 

the floating recording toolbar. VuGen closes the browser and restores the VuGen main 

window. 

 

By default, your recorded script appears in the tree view. If your script appears in the 

text-based script view, select View > Tree View to switch to the tree view. 

 

          
 

11. Select File > Save, or click the Save button to save the Vuser script. Specify a 

file name and location in the Save Test dialog box, and click Save. 

 

VuGen can display a Web Vuser script in two ways: 

 

As an icon-based representation of the Vuser script. This is the default view, and 

is known as the tree view. 

 

As a text-based representation of the Vuser script. This is known as the script 

view. 

 

To display the tree view of a Web Vuser script: 

 

 From the VuGen main menu, select View > Tree View, or click the View script 

as tree icon. The Vuser script is displayed in the icon-based tree view. If you are already 

in the tree view, the menu item is disabled. 
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The tree view of a Vuser script is composed of icons. Each icon represents an action of 

the Vuser or a step in the Web Vuser script. The icons are divided into four categories: 

 

➤ Action Icons 

➤ Control Icons 

➤ Service Icons 

➤ Web Check Icons 

 

Action Icons 

 

Each Action icon in the Vuser script represents a user action during recording, that 

is, a jump to a new Web page or a change in the Web context.  

 

VuGen uses five different Action icons, each one representing a different user 

action during recording and playback: 

 

URL 

Link 

Image 

Form/Data 

Submission 

Custom 

Request 
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Control Icons 

 

Each Control icon in the Vuser script represents a control used during load 

testing. Control steps include transactions, rendezvous points, and think time. You can 

add control steps either while recording, or after recording. 

 

VuGen uses these Control icons: 

 

Start Transaction 

End Transaction 

Rendezvous 

Think Time 

 

Service Icons 

 

A Service icon represents a step that does not make any changes in the Web 

application context. Rather, service steps perform customization tasks such as setting 

proxies, providing authorization information, and issuing customized headers. Service 

steps in a Vuser script override any run-time settings that are set for the script. 

 

Web Check Icons 

 

When you add a Web check during or after recording, VuGen adds a Web Check 

icon to the current step in the Vuser script. Web Check icons are always indented under 

the associated step. 
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Creating a Scenario using LoadRunner Controller 
 

 

To test your system with LoadRunner, you must create a scenario—a file with 

information about the test session. The scenario is the means by which you emulate a 

real-life user. The scenario contains information about how to emulate real users: the 

groups of virtual users (Vusers), the test scripts the Vusers will run, and the load 

generator machines upon which to run the scripts. 

 

 

Introducing the LoadRunner Controller 

 

To open the Controller:  

 

Select Start > Programs > LoadRunner > Controller. The Controller opens with the 

New Scenario dialog box inside.  
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You can select one of two methods to create a scenario: Manual Scenario or 

Goal-Oriented Scenario. In a manual scenario, you create the scenario yourself by 

defining the number of Vuser groups you want to run, and building a schedule for 

LoadRunner to run these groups. You can also create a manual scenario by defining the 

total number of Vusers to be used in the scenario, and assigning a percentage of the total 

number of Vusers to each script. If you want to create a scenario using the Percentage 

Mode, select Use the Percentage Mode to distribute the Vusers among the scripts. In a 

goal-oriented scenario, you define the goals you want your test to achieve, and 

LoadRunner automatically builds a scenario for you, based on these goals. 

 

 

To select the script or scripts that you want to use in your scenario:  

 

1. Select a script from the Available Scripts list. By default, the list displays the 

fifty most recently used scripts.  

 

 

2. Click the Add button to copy the script you selected to the Scripts in Scenario 

list.  

3. Click the Remove button to remove a script from the Scripts in Scenario list. 

 

4. To bypass this dialog box the next time you create a new scenario, clear the 

Show at startup check box. You will be able to add scripts later on, while building your 

scenario.  

 

5. Click OK to close the dialog box. 
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The LoadRunner Controller window contains the following elements 
 

 

 

         
 

The Controller window has two tabs which correspond to two views:  

 

Design view this view displays a list of all the Vuser groups/scripts in a scenario, 

and the load generator machines, and number of Vusers assigned to each group/script. 

This view also displays basic information about the scenario schedule (manual scenario) 

or goal (goal-oriented scenario).  
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Run view Displays information on the running Vusers and Vuser groups, as well 

as online monitor graphs.  

 

In addition, if you select View > Show Output, the Controller opens the Output 

window which displays error, warning, notification, debug, and batch messages generated 

during scenario execution.  

 

A scenario describes the events that occur during each load testing session. You 

create a scenario using the Design view of LoadRunner Controller. 

 

Creating a New Scenario  
 

You can build a manual scenario by creating groups and specifying the scripts, the 

load generators, and the number of Vusers included in each group. You can also build a 

manual scenario using the Percentage Mode, which allows you to define the total number 

of Vusers to be used in the scenario, and assign load generators and a percentage of the 

total number of Vusers to each script.  

 

If you chose to create a regular manual scenario, each script you selected in the 

New Scenario dialog box is assigned to a Vuser group. To each Vuser group you then 

assign a number of virtual users. You can instruct all Vusers in a group to run the same 

script on the same load generator machine, or you can assign different scripts and load 

generators to the various Vusers in a group.  

 

Creating Vuser Groups  

 

A scenario consists of groups of Vusers which emulate human users interacting 

with your application. When you run a scenario, the Vusers generate load on the server, 

and LoadRunner monitors the server and transaction performance.  

 

You create Vuser groups from the Scenario Groups window of the Controller. 

 

The following figure show the scenario group window. 
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To create Vuser Groups: 

 

1. Click the Add Group button to the right of the Scenario Groups window. 

The Add Group dialog box opens: 
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2. In the Group Name box, enter a name for the Vuser group.  

 

3. From the Vuser Quantity box, select the number of Vusers that you want to create in 

the group.  

 

4. Select a load generator from the Load Generator Name list. The Load Generator list 

contains all load generators that you previously added to the scenario.  

 

To use a load generator that does not appear, select Add from the Load Generator 

Name list. The Add Load Generator dialog box opens: Type the name of the load 

generator in the Name box. In the Platform box, select the type of platform on which the 

load generator is running. By default, LoadRunner stores temporary files on the load 

generator during scenario execution, in a temporary directory specified by the load 

generator’s TEMP or TMP environment variables. To override this default for a specific 

load generator, type a location in the Temporary Directory box. 

 

                 
  

 

6. Click OK to close the Add Group dialog box. The new group’s properties 

appear in the Scenario Groups window 

 

 

Adding Vusers to a Vuser Group 
 

You add Vusers to a Vuser group and define their properties using the Add 

Vusers dialog box. 

 

To add Vusers to a Vuser group: 

 

1.  In the Vusers dialog box, click the Add Vuser(s) button. The Add Vusers dialog box 

opens. 
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2. From the Group Name box, select the name of the Vuser group. 

 

3. From the Quantity to add box, select the number of Vusers that you want to add to the 

group. 

 

4. Select a load generator from the Load Generator Name list.  

 

5. Select a script from the script list. The script list contains all scripts that you previously 

added to the scenario. 

 

6. Click OK to close the Add Vusers dialog box. The new Vuser’s properties appear in 

the Vusers dialog box. 
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Running a Scenario  
 

Once you have designed your scenario, you are ready to run it. You can control 

the Vusers and Vuser groups and monitor their performance online using the Run view of 

the LoadRunner Controller. The following figure shows the Run view. 

 

During scenario execution, you use the Scenario Groups window in the Run view 

to monitor the actions of all the Vusers and Vuser groups in the scenario. The Status field 

of each Vuser group displays the current state of each Vuser in the group.  
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You can also manipulate individual Vusers within the Vuser groups you have 

defined by selecting a group and clicking the Vusers button. The Vusers dialog box 

appears, with a list of the ID, Status, Script, Load Generator, and Elapsed Time (since the 

beginning of the scenario) for each of the Vusers in the group 

 

            
 

 

Note that you can detach the Scenario Status window from the Run view, thereby 

enlarging the Scenario Groups window.  

 

While the scenario runs, the Vusers and load generators send error, notification, 

warning, debug, and batch messages to the Controller. You can view these messages in 

the Output window (View > Show Output).  
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Viewing Vusers During Execution 
 

LoadRunner lets you view Vuser activity during a scenario: 

 

 On the Controller load generator machines, you can view the Output window, 

monitor Vuser performance online, and check the status of Vusers executing the 

scenario. 

 On remote machines, you can view the Agent summary with information about 

the active Vusers. 

 

Monitoring Vuser Status 
 

During scenario execution, you can use the Scenario Groups window in the Run 

view to monitor the actions of all the Vusers and Vuser groups in the scenario. 

 

The Status field of each Vuser group displays the current state of each Vuser in 

the group. The following table describes the possible Vuser states during a scenario. 

 

Status  

 

     Description 

DOWN The Vuser is down. 

 

PENDING The Vuser is ready to be initialized and is 

waiting for an available load generator, or is 

transferring files to the load generator. The 

Vuser will run when the conditions set in its 

Scheduling attributes are met. 

INITIALIZING The Vuser is being initialized on the remote 

machine. 

READY The Vuser already performed the init section of 

the script and is ready to run. 

RUNNING The Vuser is running. The Vuser script is being 

executed on a load generator. 

RENDEZVOUS The Vuser has arrived at the rendezvous and is 

waiting to be released by LoadRunner. 

DONE.PASSED  

 

The Vuser has finished running. The script 

passed. 

DONE.FAILED  

 

The Vuser has finished running. The script 

failed. 

ERROR  

 

A problem occurred with the Vuser. Check the 

Status field on the Vuser dialog box or the 

output window for a complete explanation of 

the error. 
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GRADUAL EXITING The Vuser is completing the iteration or action 

it is running (as defined in Tools > Options > 

Run-Time Settings) before exiting. 

EXITING The Vuser has finished running or has been 

stopped, and is now exiting. 

STOPPED The Vuser stopped when the Stop command 

was invoked. 
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Inserting Steps 
 

 

You can manually add steps to your Web Vuser script. You can insert functions 

specific to the Web or Wireless protocols, or generic functions. 

 

1. Select Insert > New Step to insert a step after the selected step, or select Insert After or 

Insert Before from the right-click menu. The Add Step dialog box opens. 

 

                    
 

2. Select the function to add to the Vuser script, or expand the branch for Service or Web 

Check functions. Click OK. 

 

3. To find a function, type it in the Find Function box. The Step Type window expands 

the relevant branch and displays the functions that correspond to the letters that you 

typed. 
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Inserting Transactions 
 

You insert transactions into a Web Vuser script to enable the Controller to  

measure the performance of your Web server under various load conditions. Each 

transaction measures the time that it takes for the server to respond to one or more tasks 

submitted by Vusers. You can create transactions to measure simple tasks, such as 

accessing a URL, or complex processes, such as submitting several queries and waiting 

for a response. 

 

To define a transaction, you insert a Start Transaction and End Transaction icon 

into the Vuser script. 

 

 

                                          
 

Within a Vuser script, you can mark an unlimited number of transactions. You insert 

transaction statements into your script either while recording or after the recording 

session. 

During a scenario execution, the Controller measures the time it takes to perform 

each transaction. After a scenario run, you use LoadRunner’s graphs and reports to 

analyze the server’s performance. 

 

To mark the start of a transaction while recording: 

 

1. Click the Start Transaction button on the VuGen toolbar. The Start Transaction dialog 

box opens. 

 

 

                      
 

2. Type a transaction name in the Transaction Name box. 

 

3. Click OK to accept the transaction name. VuGen inserts an  "lr_start_transaction " 

statement in the Vuser script. 
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Example. 

 

               lr_start_transaction(" transample"); 

 

To mark the end of a transaction while recording: 

 

1. Click the End Transaction button on the VuGen toolbar. The End Transaction dialog 

box opens. 

 

                       
 

2. Click the arrow in the Transaction Name box to display a list of open transactions. 

Select the transaction to close. 

 

3. Select the transaction status from the Transaction Status list. You can manually set the 

status of the transaction, or you can allow LoadRunner to detect it automatically. 

 

 To manually set the status, you perform a manual check within the code of your 

script, evaluating the return code of a function. For the "succeed" return code, set 

the status to LR_PASS. For the "fail" return code, set the status to LR_FAIL. 

 

 To instruct LoadRunner to automatically detect the status, specify LR_AUTO. 

LoadRunner returns the detected status to the Controller. 

 

4. Click OK to accept the transaction name and status. VuGen inserts an  

      "lr_end_ transaction "statement in the Vuser script.  
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 Rendezvous Points 
 

 A rendezvous point creates intense user load on the server and enables 

LoadRunner to measure server performance under load. Suppose you want to measure 

how a web-based banking system performs when ten Vusers simultaneously check 

account information. In order to emulate the required user load on the server, you instruct 

all the Vusers to check account information at exactly the same time. 

 

 Ensure that multiple Vusers act simultaneously by creating a rendezvous point. 

When a Vuser arrives at a rendezvous point, it is held there by the Controller. The 

Controller releases the Vusers from the rendezvous either when the required number of 

Vusers arrives, or when a specified amount of time has passed.  

To Insert Rendezvous Point 
 

1. While recording a Vuser script, click the Rendezvous button on the recording 

toolbar. The Rendezvous Dialog Box opens 

 

                       
 

 

2. Type a name for the rendezvous point in the rendezvous name box. 

 

Click OK to accept the rendezvous name. VuGen inserts an lr_rendezvous statement 

into the Vuser script. 

 

 

Using Rendezvous Point 

 

 Using the Controller, you can influence the level of server load by selecting- 

which of the rendezvous points will be active during the scenario how many Vusers will 

take part in each rendezvous.  

 

For example, to test a bank server you could create a scenario that contains two 

rendezvous points. The first rendezvous ensures that one thousand Vusers 

simultaneously deposit cash. The second rendezvous ensures that another thousand 

Vusers simultaneously withdraw cash. 
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 If you want to measure how the server performs when only five hundred Vusers 

deposit cash, you can deactivate (disable) the "withdraw" rendezvous, and instruct only 

five hundred Vusers to participate in the "deposit" rendezvous. 

 

The following procedure outlines how to control load peaks on the server: 

 

1. Create the Vuser scripts by inserting the necessary rendezvous points. 

 

2. Create a scenario. 

 

 When you add a Vuser to a scenario, LoadRunner scans the associated Vuser 

script for the names of the rendezvous points and adds them to the list in the Rendezvous 

window. ]f you create another Vuser that runs the same script, the Controller adds the 

new Vuser to the rendezvous and updates the list. 

 

3. Set the level of emulated user load. You determine the exact level of load by selecting 

the rendezvous points that will take part in the scenario, and how many Vusers will 

Participate in each rendezvous. 

 

4. Set the attributes for the rendezvous (optional). For each rendezvous you can set the 

timeout and policy attributes. 

 

5. Run the scenario. 

 

 

Setting the Rendezvous Attributes 

 

 You can set the following rendezvous attributes from the Rendezvous Information 

dialog box: 

 

 • Timeout 

 • Rendezvous Policy 

 • Enabling and Disabling Rendezvous 

 • Enabling and Disabling Vusers 

 

In addition, the dialog box displays general information about the rendezvous point: 

which script is associated with the rendezvous and release history. 

 

 

 

 



  Load Runner 

Sanjay Kumar – Load Runner Tutorials 

 

Setting Timeout Behavior Attribute 

 

 The timeout determines the maximum time (in seconds) that LoadRunner waits 

for each Vuser to arrive at a rendezvous. After each Vuser arrives at the rendezvous, 

LoadRunner waits up to timeout seconds for the next Vuser to arrive. If the nest Vuser 

does not arrive within the timeout period, then the Controller releases all the Vusers from 

the rendezvous. Each time a new Vuser arrives, the timer is reset to zero. The default 

timeout is thirty seconds. You set a timeout for each rendezvous point. 

 

To set a timeout: 

 

1. Choose Scenario > Rendezvous. The Rendezvous Information dialog box opens. 

 

2. Select the Rendezvous from the Rendezvous list for which you want to set a timeout. 

 

3. In the Behavior section, locate the Timeout box. Enter a timeout value—the default is 

30 seconds. 

 

4. Click OK to close the dialog and set the timeout for the rendezvous. 

 

 

Setting the Release Policy Attribute 

 

 The policy attribute  determines   how the Controller releases Vusers  From the 

rendezvous. For each rendezvous you can set the following Policies: 

 

All Arrived Instructs the Controller to release the Vusers from the rendezvous only when 

all die Vusers included in the rendezvous arrive. All the Vusers are released 

simultaneously. 

 

The default policy is All Arrived  

 

Quota Sets the number of Vusers that must arrive at a rendezvous point before the 

Controller releases the Vusers. For instance, suppose that you are testing a scenario of 

fifty Vusers and that you want a particular operation to be executed simultaneously by ten 

Vusers. You can designate the entire scenario as participants in the Rendezvous and set a 

quota of ten Vusers. Every time ten Vusers arrive at the rendezvous, they are released. 
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To set the policy attribute: 

 

1. Choose Scenario > Rendezvous. The Rendezvous Information dialog Box opens. 

 

2. Click a rendezvous in the Rendezvous list. 

 

3. In the Behavior section, locate the Policy box. 

 

4. To set the policy to All Arrived, select All Arrived from the list. The new policy 

appears in the Policy field. 

 

5. To set the policy to Quota, select Quota from the list. The Rendezvous Quota dialog 

box appears.  Enter the number of Vusers in the Quota box 

  

 

Disabling and Enabling Rendezvous Points 

 

 You can temporarily disable a rendezvous and exclude it from the scenario. By 

disabling and enabling a rendezvous, you influence the level of server load. You use the 

Disable and Enable buttons on the Rendezvous Information dialog box, to change the 

status of a rendezvous. 

 

To disable a rendezvous: 

 

1. Choose Scenario > Rendezvous. The Rendezvous Information dialog box opens. 

 

2. Select the rendezvous you want to disable. 

 

3. Click the Disable button. The button changes to Enable and the rendezvous becomes 

disabled. 

 

 

To enable a rendezvous  

 

1. Choose Scenario > Rendezvous. The Rendezvous Information dialog box opens. 

 

2. Select the disabled rendezvous that you want to enable. 

 

3. Click the Enable button. The button changes to Disable and the rendezvous becomes 

enabled. 
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Disabling and Enabling Vusers at Rendezvous Points 

 

 In addition to disabling a rendezvous for all Vusers in a scenario. LoadRunner lets 

you disable it for specific Vusers. By disabling Vusers at a rendezvous, you temporarily 

exclude them from participating in the rendezvous. Enabling disabled Vusers returns 

them to the rendezvous. You use the Disable and Enable commands to specify which 

Vusers will take part in a rendezvous. 

 

To disable a Vuser in a rendezvous: 

 

1. Choose Scenario > Rendezvous. The Rendezvous Information dialog box opens. 

 

2. Select the rendezvous from the Rendezvous list for which you want to disable Vusers. 

 

3. Click OK to insert the comment and close the dialog box. The text is placed at the 

current point in the script, enclosed by comment markers. 

 

The following script segment shows how a comment appears in a Vuser script: 

 

Note: You can insert comments into your script after you complete a recording session, 

by selecting Insert > Comment from the VuGen menu. 

 

/* 

* This is the first query 

*/ 

 

4. In the section Enable/Disable Vusers, select the Vuser(s) you want to exclude from 

die rendezvous. Select multiple Vusers using the CTRL key. 

 

5. Click Disable (the button directly below the Vuser list). The disabled Vusers change 

from black to gray and will not take part in the rendezvous. 

 

6. To enable a Vuser, select it and click Enable. 
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Scheduling a Scenario  
 

After you create a scenario, you can set the time at which the scenario will begin 

running. In addition, for a manual scenario, you can set the duration time of the scenario 

or of the Vuser groups within the scenario. You can also select to gradually run and stop 

the Vusers within the scenario or within a Vuser group.  

Load runner provides several scheduling options for scenario execution. 

-    Delaying the scenario start 

-    Limiting the scenario duration 

You can instruct LoadRunner to begin executing a scenario with a delay. You can 

specify the number of minutes to wait from the time a run command is issued, until the 

scenario begins. 

You can also limit the time duration of a scenario. You specify the number of 

minutes a scenario should be in the running state. When a scenario reaches its time 

limitation, it finishes. 

Delaying the Start of a Scenario For both manual and goal-oriented scenarios, you 

can instruct LoadRunner to start running the scenario at a later point in time. You can 

specify either the number of minutes you want LoadRunner to wait from the time a Run 

command is issued, or the specific time at which you want the scenario to begin.  

To delay the start of the scenario:  

1. Select Scenario > Start Time. The Scenario Start dialog box opens, with the default 

option, without delay is selected. 
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2. Select with a delay of X (HH: MM: SS) and enter the amount of time (in hours: 

minutes: seconds format) by which you want to delay the start of your scenario.  

Alternatively, you can select at X (HH: MM: SS) on X and specify the time (in hours: 

minutes: seconds format) and date for the start of the scenario.  

 

3. Click OK to close the dialog box and save your settings.  

 

 

Getting started with LoadRunner scheduler 
 

1) Create a scenario using LoadRunner controller 

 

2) Start->programs->LoadRunner->scheduler-> LoadRunner scheduler is opened. 

 

3) View menu->schedule layout->  

 

Basic time event /basic mode - is used if you only want to schedule group 

execution times. 

 

Expert Time event - if you want to specify dependencies, sequences, 

command events or delay events 

 

4) Schedule menu-> schedule group-> select the group that are to be scheduled and 

select the startup time. 

 

5) Set the timing properties->set the timing related specifications for the scenario such 

as duration, initialization, ramp up, ramp down 

 

6) Create a schedule external events->define delays and external events and 

schedule them at the desired points. This setting only applies to expert event    I mode. 

 

Basic Time- Event Mode 

 

The Basic time- event mode lets you schedule groups based on time. You configure the 

properties for each group separately. 

 

The available properties are Duration, Initializing, Ramp Up, and Ramp Down. 

 

Duration: The amount of time the current group participates in the scenario. 

 

Initializing:   the number of Vusers to initialize to the ready state during the specified 

time interval, this emulates a logon procedure usually done once a day. 
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Ramp Up: The pace at which Vusers run this script (i.e. Transition from Ready to Run 

state). This usually emulates actions that are repeated multiple times. 

 

Ramp down: The pace at which Vusers are terminated, this setting is only available if 

the group is set to run for a fixed duration. 

 

Expert Time- Event Mode 
 

The Expert Time- Event mode provides additional scheduling capabilities: 

 

 Dependencies  

 Sequencing 

 Command Events 

 Delay Events 

                           

 

Defining External Events 

 

The LoadRunner Scheduler allows us to schedule external events or tasks not included in 

our Vuser script 

 

Two types of external events: 

 

 Command Events 

 Delay Events 

 

Note: To create external events you must enable the Expert event mode.  

 

Command Events 

 

A Command event is an external task that must be executed during the scenario. 

For example, you may need to initialize a system, restore a database, or start a monitor 

during a scenario run. 

 

Before scheduling a Command event, you must define a list of commands. These 

commands can either be an executable program or a batch file. When you schedule 

multiple commands, you can indicate whether to execute them in parallel or sequentially. 

 

In normal operation, the scheduler waits until all of the commands in the list 

have been completed before continuing with the next scheduled group or event. 
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To create a Command event: 

 

1. Verify that you are working in Expert mode.  

 

To enable Expert mode, select View > Scheduler Layout > Expert Time- 

Event in the LoadRunner Scheduler window. 

 

2. Choose Edit > Create Command Event or click the Create Command Event button. 

The Command Properties dialog box opens. 

 

3. Specify an alias name for the list of command events in the Alias box. 

 

4. Click the Browse button near the Command- line operation box and locate a batch 

or executable file. 

 

5. Click Add to add the event to the list.  Repeat the above steps for all the commands 

you need to execute. 

 

6. By default, the Scheduler executes the commands sequentially. To run the 

commands simultaneously, select Execute commands in parallel. 

 

7. Clicks OK. 

 

8. To schedule an event choose Schedule > Schedule Event or click on the Add Group 

button. The Select Event and Start Time dialog box opens. Select the event you want to 

schedule and specify a start time. 

 

 

Delay Events 
 

To insert a delay into your scenario, you schedule a Delay event. This event 

instructs LoadRunner to wait the specified amount of time before resuming with the 

next action. The delay may be a fixed or random value. This feature may be useful if 

you want to wait for your system to stabilize before continuing. Unlike groups, Delay 

events are reusable. You can include the same delay in multiple locations in the 

scenario schedule. 
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To Create a Delay event: 

 

1. Verify that you are working in Expert mode.  

 

To enable Expert mode, select View > Scheduler Layout > Expert Time- 

Event in the Load Runner Scheduler window. 

 

2. Choose Edit > Create Delay Event or click the Create Delay Event button. The 

Delay Properties dialog box opens. 

 

3. Specify an alias name for the Delay event in the Alias box. 

 

4. To wait a fixed amount of time between events, select Wait for fixed amount of 

time and specify time duration. 

 

5. To wait a random amount of time between events, select Wait a random delay 

and specify a minimum and maximum for the random value. 

 

6. Click OK. 

 

 

Scheduling a Scenario Using the Schedule Builder 

 

 you can control the execution of your scenario by:  

 

 Limiting the scenario duration  

 Gradually running Vusers within a scenario 

 Gradually stopping Vusers within a scenario 

 

 

To set the scheduling options for a scenario:  
 

1. Select the Schedule By Scenario option.  
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2. To determine how to start the scenario, click the Ramp Up tab.  

 

Choose one of the following options:  

 

 Load all Vusers simultaneously: Starts all the Vusers in the scenario at once. 

 

 Start X Vusers every X (HH:MM:SS): Begins running the specified number of 

Vusers concurrently, and waits the specified time between Vuser ramp ups.  

 

3. To set the duration of the scenario, click the Duration tab.  
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Choose one of the following options:  

 

 Run until completion   

 Run for X (HH:MM:SS) after the ramp up has been completed: Runs the scenario 

for a specified amount of time, once all the Vusers have been ramped up.  

 Run indefinitely  

 

4. To determine how to stop the scenario, click the Ramp Down tab. 

 

 

                    
 

 

    Choose one of the following options:  

 

  Stop all Vusers simultaneously: Stops all the Vusers in the scenario at once.  

  Stop X Vusers every X (HH:MM:SS): Stops a certain number of Vusers within a 

specified time frame.  

 

5. To instruct LoadRunner to initialize Vusers before beginning to load them, select 

Initialize all Vusers before ramp up.  

 

Note that LoadRunner will only begin to load the Vusers once they have all reached the 

READY state.  

 

6. Click OK to close the Schedule Builder and save your settings.  
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Scheduling Vuser Groups  

 

After you create a Vuser group, you can schedule the group’s script execution by 

setting: 

  

 The amount of time after the start of the scenario that the group must wait before 

it starts running.  

 The number of Vusers that will run within a specified period of time.  

 The number of Vusers that will be stopped within a specified period of time.  

 The amount of time the group will run. 

  

 

To schedule a Vuser Group:  

 

1. Select the Scheduling By Group option.  

 

                
 

2. Select a group from the box on the left.  

 

3. To set the start time for the group, click the Start Time tab.  
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Choose one of the following three options:  

 

 Start the group at the beginning of the scenario  

 Start X after the scenario begins: Waits the specified amount of time before 

running the group.  

 Start when group X finishes: Begins running the group after the specified group 

has finished running.  

 

4. To set the ramp up for the group, click the Ramp Up tab.  

 

                 
 

 

Choose one of the following options:  

 

 Load all of the Vusers simultaneously: Starts all the Vusers in the at once.  

 

 Start X Vusers every X (HH:MM:SS): Begins running the specified number of 

Vusers concurrently, and waits the specified time between Vuser Ramp Up.  

 

5. To set the duration of the group, click the Duration tab. 
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Choose one of the following options:  

 

 Run until completion  

 

 Run for X (HH:MM:SS) after the ramp has been completed: Runs the group for 

the specified amount of time, once all the Vusers have been ramped up.  

 

6. To determine how to stop the Vuser group, click the Ramp Down tab.  

 

 

                    
 

Choose one of the following options:  

 

 Stop all Vusers simultaneously: Stops all the Vusers in the group at once. 

 

 Stop X Vusers every X (HH:MM:SS): Stops a certain number of Vusers within a 

specified time frame. 

 

7. Click OK to close the Schedule Builder and save your settings. 
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      Monitoring a Scenario 
 

  Monitoring scenario execution using the LoadRunner online transaction, Web 

server resource, Database server resource and Java performance monitors. 

 

 The following describes the online monitor user interface: 

 

 

 Starting the Monitors. 

 Configuring Online Monitors. 

 Setting Monitor Options. 

 Configuring Online Graphs. 

 Configuring Online Measurements. 

 Exporting Online Monitor Graphs. 

 Viewing Data Offline 

 

Online Monitoring 

 

LoadRunner provides the following online monitors: 

 

 Run-Time monitor displays the number and status of Vusers 

participating in the scenario, as well as the number and types of errors 

that the Vusers generate. It also provides the User-Defined Data Point 

graph that displays the real-time values for user-defined points in a 

Vuser script. 

 

 Transaction monitor displays the transaction rate and response time 

during scenario execution. 

 

 Web Resource monitors measures statistics at the Web server(s) during 

scenario runs. It provides information about the number of Web 

connections, throughput volume, HTTP responses, server retries, and 

downloaded pages during the scenario.  
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 Network Delay monitor displays information about the network delays 

on your system. To activate the Network Delay monitor, you must set 

up the network paths to monitor before you run your scenario.  

 

 The Firewall monitor measures statistics at the firewall servers during 

the scenario. To activate the Firewall monitor, you must set up a list of 

resources to monitor before you run your scenario.  

 

 The Database Server Resource monitors measure statistics related to 

the SQL server, Oracle, Sybase, and DB2 databases. To activate the 

Database Server Resource monitors, you must set up a list of 

measurements to monitor before you run your scenario.  

 

 The Streaming Media monitors measure statistics at the Windows 

Media Server and RealPlayer audio/video servers, as well as the 

RealPlayer client. To activate the Streaming Media monitors, you must 

set up a list of resources to monitor before you run your scenario.  

 

 The ERP Server Resource monitor measures statistics at the ERP 

servers during the scenario. To activate the ERP Server Resource 

monitor, you must set up a list of resources to monitor before you run 

your scenario.  

 

 The Java Performance monitors measure statistics of Enterprise Java 

Bean (EJB) objects and Java-based applications, using EJB, JProbe, 

Sitraka JMonitor, and TowerJ Java virtual machines. To activate the 

Java Performance monitors, you must set up lists of resources to 

monitor before you run your scenario.  

 

Starting the Monitors 
 

To start the online monitors: 

 

1. Start the scenario. Select the Vuser groups you want to run and click the Start 

Scenario button, or choose Scenario > Start. 

 

2. Click the Run tab. The default graphs are displayed below the Scenario Groups 

window. 
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3. Double-click a graph to maximize it. Repeat the operation to restore the tiled view. 

 

4. Click the "+" in the left pane to expand the graph tree. To hide the graph tree view, 

select View > Hide Available Graphs, or click the X button in the right-hand corner of 

the Available Graphs list. 

 

5. Select a graph from the tree and drag it into the right pane. You can also drag graphs 

between panes. 

 

 

Configuring Online Monitors 
 

 Using LoadRunner it is possible to configure the settings for your online 

monitors. And also, we can set graph measurements and properties, such as the sampling 

time, the colors of the lines, and the scale of the graph. 

 

Monitor options: global sampling rate, error handling, debugging, and the frequency 

settings.  
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Graph properties: refresh rate, display type, graph time for the x-axis, and the y-axis 

scale.  

 

Measurement settings: line color, scale of the y-axis, and whether to show or hide the 

line.  

 

 

Setting Monitor Options 
 

 Before running your scenario, you can set monitor options in the following areas: 

 

 Sampling Rate: The sampling rate is the period of time (in seconds) 

between consecutive samples. By default, the online monitor samples 

the data at intervals of three seconds. If you increase the sampling rate, 

the data is monitored less frequently. This setting applies to all graphs.  

 

 Error Handling: You indicate how LoadRunner should behave when a 

monitor error occurs—issue a popup message box (default) or send error 

messages to the Output window. 

 

  Debug: The online monitor provides debugging capabilities. It displays 

the debug messages in the output log. For the Network monitor, you can 

indicate the debug (detail) level of messages sent to the log, ranging 

from 1-9.  

 

 Frequency: You set the frequency at which the monitor sends updates 

to the Controller for the Transaction, Data Point, and Web Resource 

graphs. The data is averaged for the frequency period defined, and only 

one value is sent to the Controller. 

 

To set monitor options: 

 

1. Select Tools > Options and select the Monitors tab. 

 

2. Specify the frequency at which the monitor should send updates to the Controller for 

the Transaction, Data Point, and Web Resource graphs. The default value is 5 seconds. 

For a small scenario, it is recommended that you use a frequency of 1. For a large 

scenario, it is recommended that you use a frequency of 3-5.  
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3. Enter a sampling rate. 

 

4. Set the desired Error Handling option. 

 

5. To display debug messages in the Output window, select the Display Debug Messages 

check box. For the Network monitor, specify a Debug level from 1-9.  

 

6 Click OK to save your settings and close the Options dialog box. 

 

 

Configuring Online Graphs 
 

You can customize your graph in the following areas: 

 

 Refresh Rate : The refresh rate is the interval in which the graph is 

refreshed with new data. By default, the graph is refreshed every five 

seconds. If you increase the refresh rate, the data is refreshed less 

frequently.  

 

 X-Axis Style : By using this it is possible to displays the x-axis time: 

Don’t Show, Clock Time, or Relative to Scenario Start. The Don’t Show 

setting instructs LoadRunner not to display values for the x-axis. The 

Clock Time setting displays the absolute time, based on the system 

clock. The Relative to Scenario Start setting displays the time relative to 

the beginning of the scenario.  

 

In the following example, the graph is shown with the Don’t Show and Clock Time 

options: 
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 Graph Time : The Graph Time settings indicate the scale for a graph’s 

x-axis when it is time-based. A graph can show 60 or 3600 seconds of 

activity. To see the graph in greater detail, decrease the graph time. To 

view the performance over a longer period of time, increase the graph 

time. The available graph times are: Whole scenario, 60, 180, 600, and 

3600 seconds.  

 

 Display Type :You can specify whether LoadRunner displays the 

Network Delay Time graph as a line, pie, or area graph. By default, the 

graph is displayed as a line graph.  

 

 Y-Axis Style You can instruct LoadRunner to display graphs using the 

default y-axis scale, or you can specify a different y-axis scale. Click 

Automatic if you want LoadRunner to use the default y-axis values.  

 

To customize your graphs: 

 

1. Select the online graph you want to configure (in either the right or left pane) and 

choose Monitors > Online Graphs > Configure. Alternatively, right-click a graph and 

select Configure. The Graph Configuration dialog box opens. 

 

2. To apply the dialog box settings to all graphs, select Apply to all graphs. 

 

3. Enter the desired refresh rate—the time between graph updates—in the Refresh Rate 

box. 

 

4. Select a style for the x-axis from the Time box. 
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5. Select a value from the Graph Time box. The graph time is the time in seconds 

displayed by the x-axis. 

 

6. For the Network Delay Time graph, select a graph style (Line, Pie, or Area) from the 

Display Type box. 

 

7. Select a maximum or minimum value for the y-axis, or choose Automatic to view 

graphs using the default y-axis scale. 

 

8. Click OK to save your settings and close the Graph Configuration dialog box. 
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Configuring Online Measurements 
 

You can configure the following online measurement settings: 

 

 Changing Line Colors: LoadRunner assigns a unique color to each 

measurement. You can modify the color using the configuration 

interface.  

 

 Setting the Scale of the Measurement : You can modify the scale of a 

measurement—the relationship between the y-axis and the graph’s 

actual value. For example, a scale set at 1 indicates that the 

measurement’s value is the value of the y-axis. If you choose a scale of 

10, you must divide the y-axis value by 10 to obtain the true value of the 

measurement. 

 

In the following example, the same graph is displayed with a scale of 1 and 10. 

 

                           
 

 

 Showing and hiding resources : By default, the resource monitor 

displays a line for each item in the resource list. You can hide the line 

for any of the monitored resources in order to focus on a specific 

measurement and scale factor. 
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Exporting Online Monitor Graphs 
 

 LoadRunner allows you to export the online graph to HTML for viewing at a later 

stage. When you export to HTML, the legend is also displayed with the graph. You can 

export all graphs or only the selected one. 

 

To export online graphs to HTML: 

 

1. To export a specific graph, select the graph you want to export and choose Monitors > 

Online Graphs > Export to HTML. The Select Filename and Path dialog box opens. 

 

2. To export all graphs in the Online Monitor view, choose Monitors > Export Online 

Graphs to HTML. The Select Filename and Path dialog box opens.  

 

3. Specify a filename and path and click Save. 

 

 

Viewing Data Offline 
 

 After monitoring resources during a scenario run, you can view a graph of the 

data that was gathered using the LoadRunner Analysis. When you run the Analysis 

utility, it processes the data and generates a graph for each measurement that was 

monitored. 

 



  Load Runner 

Sanjay Kumar – Load Runner Tutorials 

 

      LoadRunner Analysis 
 

 

 During scenario execution, Vusers generates results of data as they perform their 

transactions. To monitor the scenario performance during test execution, use the online 

monitoring tools. To view a summary of the results after test execution, you can use one 

or more of the following tools:  

 

 Vuser log files contain a full trace of the scenario run for each Vuser. These 

files are located in the scenario results directory. (When you run a Vuser script 

in standalone mode, these files are placed in the Vuser script directory.)  

 

 Controller Output window displays information about the scenario run. If 

your scenario run fails, look for debug information in this window.  

 

 Analysis graphs help you determine system performance and provide 

information about transactions and Vusers. You can compare multiple graphs by 

combining results from several scenarios or merging several graphs into one.  

 

 Graph Data and Raw Data views display the actual data used to generate the 

graph in a spreadsheet format. You can copy this data into external spreadsheet 

applications for further processing.   

 

 Report utilities enable you to view a Summary HTML report for each graph or 

a variety of Performance and Activity reports.  

 

 

 

Starting the Analysis  
 

 The analysis is the LoadRunner component that processes results gathered during 

a scenario execution and generates graphs and reports. You can open the Analysis 

through the LoadRunner program group as an independent application, or directly from  

the Controller.  

 

 To open the new Analysis utility as an independent application, choose 

Analysis from the LoadRunner Program Group 

  

 To open the Analysis directly from the Controller, select Results > Analyze 

Results. This option is only available after running a scenario.  
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Collating Execution Results  

 

 When you run a scenario, by default all Vuser information is stored locally on 

each Vuser host. After scenario execution the results are automatically collated or 

consolidated—results from all of the hosts are transferred to the results directory.  

 

 Disabling automatic collation, by choosing Results > Auto Collate Results from 

the Controller window, to clear the check mark adjacent to the option.  

 

 To manually collate results, choose Results > Collate Results. If your results 

have not been collated, the Analysis will automatically collate the results before 

generating the analysis data.  

 

 

 

Viewing Summary Data  
 

 In large scenarios, with results exceeding 100 MBs, it can take a while for the 

Analysis to process the data. While LoadRunner is processing the complete data, you can 

view a summary of the data collected.  

 

 To view the summary data, choose Tools > Options, and select the Result 

Collection tab. Select Display summary data while generating complete data if you 

want the Analysis to process the complete data graphs while you view the summary data, 

or select Generate summary data only if you do not want LoadRunner to process the 

complete Analysis data.  

 

Note : The following graphs are not available when viewing summary data only: 

Rendezvous, Data Point (Sum), Web Page Breakdown, Network Monitor, and Error 

graphs. 
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Analysis Graphs  

 
The Analysis graphs are divided into the following categories:  

 

 

 Vuser graphs display information about Vuser states and other Vuser 

statistics.  

 

 Error graphs provide information about the errors that occurred during 

the scenario.  

 

 Transaction graphs provide information about transaction performance 

and response time.  

 

 Web Resource graphs provide information about the throughput, hits 

per second, HTTP responses per second, number of retries per second, 

and downloaded pages per second for Web Vusers.  

 

 Web Page Breakdown graphs provide information about the size and 

download time of each Web page component.  

 

 User-Defined Data Point graphs display information about the custom 

data points that were gathered by the online monitor.  

 

 System Resource graphs show statistics relating to the system 

resources that were monitored during the scenario using the online 

monitor.  
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Working with Analysis Graphs 

 

  

 The Analysis provides a number of utilities that enable you to customize the 

graphs in your session so that you can view the data displayed in the most effective way 

possible.  

 

Using the Analysis utilities, you can determine : 

 

 Point’s coordinates or drill down on a graph.  

 Enlarge a section of a graph.  

 Change the granularity of a graph’s x-axis. 

 View a graph’s data as a spreadsheet or as raw data. 

 

Determining a Point’s Coordinates 

 

 You can determine the coordinates and values at specific points in a graph. Place 

the cursor over the point you want to evaluate. The Analysis displays the axis values and 

other grouping information. The following figure represents the point’s coordinates. 

 

 

                             
 

 

 

Enlarging a Section of a Graph 

 

 Graphs initially display data representing the entire duration of the scenario. You 

can enlarge any section of a graph to zoom in on a specific period of the scenario run. For 

example, if a scenario ran for ten minutes, you can enlarge and focus on the scenario 

events that occurred between the second and fifth minutes. 
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To zoom in on a section of the graph: 

 

1. Click inside a graph. 

 

2. Move the mouse pointer to the beginning of the section you want to enlarge, but not 

over a line of the graph. 

 

3. Hold down the left mouse button and draw a box around the section you want to 

enlarge. 

 

4. Release the left mouse button. The section is enlarged. 

 

5. To restore the original view, choose Clear Display Option from the right click menu. 

 

 

Changing the Granularity of the X-Axis 

 

 You can make the graphs easier to read and analyze by changing the granularity 

(scale) of the x-axis. The maximum granularity is half of the graph’s time range. To 

ensure readability and clarity, the Analysis automatically adjusts the minimum 

granularity of graphs with ranges of 500 seconds or more. 

 

To change the granularity of a graph: 

 

1. Click inside a graph. 

 

2. Select View > Set Granularity, or click the Set Granularity button. The Granularity 

dialog box opens. 

 

                                    
  

3. Enter a new granularity value in milliseconds, minutes, seconds, or hours. 

 

4. Click OK. 
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For example, the Hits per Second graph is displayed using different granularities. The   

y-axis represents the number of hits per second within the granularity interval.  

 

For a granularity of 1, the y-axis shows the number of hits per second for each one 

second period of the scenario.  

 

For a granularity of 5, the y-axis shows the number of hits per second for every five-

second period of the scenario. 

 

For a granularity of 10, the y-axis shows the number of hits per second for every ten-

second period of the scenario 

 

                                        
 

  

 In the above graphs, the same scenario results are displayed in a granularity of 1, 

5, and 10. The lower the granularity, the more detailed the results. For example, using a 

low granularity as in the upper graph, you see the intervals in which no hits occurred. It is 

useful to use a higher granularity to study the overall Vuser behavior throughout the 

scenario. By viewing the same graph with a higher granularity, you can easily see that 

overall, there was an average of approximately 1 hit per second. 
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Viewing the Data as a Spreadsheet and as Raw Data 

 

The Analysis allows you to view graph data in two ways: 

 

 

Spreadsheet View 

 

 You can view the graph displayed by the Analysis in spreadsheet format using the 

Graph Data tab below the graph. 

 

 

                         
 

 

 

Raw Data View  

 You can view the actual raw data collected during test execution for the active 

graph. The Raw Data view is not available for all graphs.  

Viewing the raw data can be especially useful for:  

 Determining specific details about a peak—for example, which 

Vuser was running the transaction that caused the peak value(s).  

 Performing a complete export of unprocessed data for your own 

spreadsheet application.  
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Understanding Analysis Reports 

 

 After running a scenario, you can view reports that summarize your system’s 

performance. The Analysis provides the following reporting tools: 

 

 Summary report: The Summary report provides general information 

about the scenario run. You can view the Summary report at any time 

from the Analysis window. 

 

 HTML reports: The Analysis creates an HTML report for each one of 

the open graphs. 

 

 Transaction reports: Transaction reports provide performance 

information about the transactions defined within the Vuser scripts. 

These reports give you a statistical breakdown of your results and allow 

you to print and export the data. 

 

Viewing Summary Reports 

 

 The Summary report provides general information about scenario execution. This 

report is always available from the tree view or as a tab in the Analysis window. It lists 

statistics about the scenario run and provides links to the following graphs: Running 

Vusers, Throughput, Hits Per Second, HTTP Responses per Second, Transaction 

Summary, and Average Transaction Response Time.  

 

 

Creating HTML Reports 

 

 The Analysis lets you create HTML reports for your scenario run. It creates a 

separate report for each one of the open graphs and a Summary report. The Summary 

report is identical to the Summary report that you access from the Analysis window. The 

report also provides a link to an Excel file containing the graph data. 

 

To create HTML reports: 

 

1. Open all graphs that you want to be included in the report. 

 

2. Choose Reports > HTML Report or click the Create HTML Report button. The 

Select Report Filename and Path dialog box opens. 

 

3. Specify a path and file name for the HTML report and click OK. 
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4. To view an HTML report for one of the graphs, click on its link in the left frame. 

 

5. To copy the HTML reports to another location, be sure to copy the filename and the 

folder with the same name. For example, if you named your HTML report test1, copy 

test1.html and the folder test1 to the desired location. 

 

Working with Transaction Reports 

 

LoadRunner’s Transaction reports are divided into the following categories: 

 

 Activity reports provide information about the number of Vusers and the 

number of transactions executed during the scenario run. The available Activity 

reports are Scenario Execution, Failed Transaction, and Failed Vusers. 

 

 Performance reports analyze Vuser performance and transaction times. The 

available Performance reports are Data Point, Detailed Transaction, and 

Transaction Performance by Vuser. 

 

 

Note : In order to view a report, you must generate it from the Analysis window. 

LoadRunner reports are displayed in a Report Viewer. You can print, save, or export the 

data using the viewer. 

 

Selecting and Displaying Reports 

 

 The Analysis provides several built-in reports which contain detailed summaries 

about the scenario, the transactions and Vusers. 

 

To display a report: 

 

1. Open the desired Analysis session file (.lra extension), or LoadRunner result file (.lrr 

extension), if it is not already open. 

 

2. From the Reports menu choose a report. The report is generated and displayed. You 

can display multiple copies of the same report. 
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Scenario Execution Report 

 

 The Scenario Execution report is an Activity report that provides details about 

major events that occurred during the scenario run. This includes information on every 

Vuser, such as when it was ready to run and for how long it ran. 

 

 

        

          
 

Failed Transaction Report 

 

 The Failed Transaction report is an Activity report that provides details about the 

beginning time, end time, and duration of the failed, but completed transaction. 

 

Failed Vuser Report 

 

 The Failed Vuser report is an Activity report that provides details about all Vusers 

that were in the ERROR, STOPPED, or DONE:FAILED states during the scenario 

execution. The Ready At and Running At times are relative to the computer’s system 

clock. 
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In this scenario, all five Vusers were stopped. 

 

 

 
Detailed Transaction Report 

 

 The Detailed Transaction (by Vuser) report is a Performance report that provides 

a list of all transactions executed by each Vuser during a scenario. The report provides 

details about the execution time of each transaction per Vuser. 

 

The following values are reported: 

 

 

Start time: the system time at the beginning of the transaction 

 

End time: the actual system time at the end of the transaction, including the think time 

and wasted time. 

 

 
 

Duration: the duration of the transaction in the following format:  

hrs:minutes:seconds:milliseconds. This value includes think time, but does not include 

wasted time. 
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Think time: the Vuser’s think time delay during the transaction. 

 

Wasted time: the LoadRunner internal processing time not attributed to the transaction 

time or think time. (primarily RTE Vusers) 

 

Results: the final transaction status, either Pass or Fail. 

 

 

 


